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How to solve the problem of interactive whiteboard SDK login failure on the Web platform?

2021-11-18
Products / Plugins:Interactive whiteboard
Platform / Framework:Web

Problem Description

After integrating the interactive whiteboard SDK on the Web platform and initializing it, login failure occurs.

Problem Cause

Login failure is generally caused by the following reasons:

  1. Network exception.
  2. Abnormal parameters passed during initialization.
  3. Abnormal parameters passed during login.
Note

The interactive whiteboard SDK on the Web platform includes all functions of the Video Call SDK. The initialization and login process is exactly the same as the Video Call SDK.

Solution

For the causes of login failure, ZEGO provides the following troubleshooting methods:

  1. First check whether the network is normal.
  2. Check the format and validity of the appID and server passed during initialization.
Note

Please ensure that the appID and server are applied through the ZEGOCLOUD Console and have not been modified.

  1. Check the format and validity of the parameters passed during login, especially the Token parameter.
Note

The Token logic needs to be implemented by the developer's business server, or you can use the temporary Token generated by the ZEGOCLOUD Console for debugging.

  1. Troubleshoot based on the error code returned by the SDK.
  1. For SDK initialization, please refer to Video Call SDK Initialization.
  2. For login interface, please refer to Video Call SDK Login.
  3. For error codes related to room login, please refer to Related Error Codes.

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