How to solve the problem of interactive whiteboard SDK login failure on the Web platform?
Problem Description
After integrating the interactive whiteboard SDK on the Web platform and initializing it, login failure occurs.
Problem Cause
Login failure is generally caused by the following reasons:
- Network exception.
- Abnormal parameters passed during initialization.
- Abnormal parameters passed during login.
The interactive whiteboard SDK on the Web platform includes all functions of the Video Call SDK. The initialization and login process is exactly the same as the Video Call SDK.
Solution
For the causes of login failure, ZEGO provides the following troubleshooting methods:
- First check whether the network is normal.
- Check the format and validity of the appID and server passed during initialization.
Please ensure that the appID and server are applied through the ZEGOCLOUD Console and have not been modified.
- Check the format and validity of the parameters passed during login, especially the Token parameter.
The Token logic needs to be implemented by the developer's business server, or you can use the temporary Token generated by the ZEGOCLOUD Console for debugging.
- Troubleshoot based on the error code returned by the SDK.
Related Links
- For SDK initialization, please refer to Video Call SDK Initialization.
- For login interface, please refer to Video Call SDK Login.
- For error codes related to room login, please refer to Related Error Codes.
