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How to resolve video anomalies (such as black screen, green screen, corrupted screen, etc.) when Web platform and Native platform interoperate?

2024-04-03
Products / Plugins:Video Call / Audio Call / Live streaming
Platform / Framework:iOS / Android / macOS / Windows / Web

Problem Description

When Web platform users receive video sent by Native platform users, or Native platform users receive video sent by Web platform users, the receiving end sees a black screen, green screen, corrupted screen, etc.

Note

Native platform mainly refers to Android, iOS, macOS, and Windows platforms.

Problem Cause

Since the video stream sent by the Native SDK is encoded with H.264 by default, this issue may be caused by an exception when decoding the H.264 video stream.

Solution

You can perform the following steps:

  1. Call the checkSystemRequirements interface to check whether the current browser supports H.264 encoding format. If it does not support this encoding, it cannot interoperate with the Native platform.
  2. It is recommended that both Native platform and Web platform use the latest version of the SDK.
  3. It is recommended that the Web platform use the latest version of Chrome browser and try to disable hardware acceleration:
    1. Enter "chrome://flags" in the browser address bar.
    2. Set both Hardware-accelerated video decode and Hardware-accelerated video encode to "Disabled".
    3. Click "Relaunch" to restart the browser.

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